Resolução e Gabarito ISS Curitiba – Tecnologia da Informação

por: Arthur Mendonça | maio 06 2019 | Direção Concursos, Espaço Concurseiro | 1 comments

Olá, pessoal!

Segue a minha correção das questões de Tecnologia da Informação do ISS Curitiba. A prova não veio muito diferente do que esperávamos, já que todos os assuntos foram abordados no nosso curso.

Como tivemos poucas questões da nossa matéria, aproveitei para resolver também a questão de Excel, que foi um assunto abordado pelo Prof. Victor Dalton. Espero que vocês tenham se saído bem.

Aí vão os comentários:

Seja a seguinte fórmula aplicada nessa planilha na célula B9:

=PROCV(A4;A1:D7;CORRESP(C1;A1:D1;0);0)

Levando em consideração os dados apresentados, assinale a alternativa que apresenta o resultado da
execução dessa fórmula.

a) R$ 355,00.
►b) R$ 980,00.
c) R$ 1.000,00.
d) R$ 1.200,00.
e) R$ 1.440,00.


RESOLUÇÃO:

A sintaxe da função PROCV é a seguinte (retirado de https://support.office.com/pt-br/article/procv-função-procv-0bbc8083-26fe-4963-8ab8-93a18ad188a1):

=PROCV(Valor que você deseja pesquisar; intervalo no qual você deseja pesquisar o valor; o número da coluna no intervalo contendo o valor de retorno; Correspondência Exata ou Correspondência Aproximada – indicado como 0/FALSO ou 1/VERDADEIRO).

Temos os seguintes parâmetros na função dada pela banca:

  • Valor a pesquisar: A4, ou seja, Março.
  • Intervalo: A1:D7, ou seja, a tabelinha inteira.
  • Coluna de retorno: Dada por CORRESP(C1;A1:D1;0)
  • Correspondência exata/aproximada: 0 (Falso), ou seja, correspondência exata.

Veja que o PROCV, então, irá buscar na tabela dada por A1:D7 o valor correspondente de forma exata ao mês de março. Com isso ainda não somos capazes de responder a questão, pois o número da coluna que irá conter o valor a ser retornado será dado pela avaliação da função CORRESP(C1;A1:D1;0).

Vamos avaliá-la: A função CORRESP busca um valor dentro de um intervalo de células (dado por uma matriz), retornando a
posição desse valor. Ela possui a seguinte sintaxe:

= CORRESP(valor_procurado, intervalo, [tipo_correspondência])

Na questão, os parâmetros da função são:

  • valor_procurado: C1
  • intervalo: A1:D1
  • tipo_correspondência: 0, o que quer dizer que a função irá localizar o primeiro valor na matriz_procurada que é
  • exatamente igual ao valor_procurado.

Assim, veja que, dentro do intervalo considerado (A1:D1), a coluna C1 é a terceira. Portanto, CORRESP(C1;A1:D1;0) irá retornar o valor 3!

Seja a seguinte consulta SQL:

SELECT DISTINCT c.data, max(p.valor)

FROM tb_cardapio c
JOIN tb_cardapio_prato cp ON c.codigo = cp.codigo_cardapio
JOIN tb_prato p ON cp.codigo_prato = p.codigo
GROUP BY c.data

Assinale a alternativa que apresenta a descrição dos dados retornados por essa consulta.


a) As datas em que o cardápio não atinge o valor máximo total.
b) As datas dos cardápios em que o prato mais caro não está associado.
c) As datas e a soma dos valores dos pratos no cardápio nesse dia.
►d) As datas e o valor do prato mais caro do cardápio nesse dia.
e) As datas dos cardápios e o valor médio dos pratos nesse dia.

RESOLUÇÃO:

Como vimos durante o curso, o examinador utiliza os comandos DDL para descrever o banco de dados utilizado. Veja que são criadas três tabelas, uma chamada tb_cardapio, outra chamda tb_prato e a tb_cardapio_prato que é utilizada para relacionar as duas (os nomes das tabelas são intuitivos!).

Em relação à consulta, observe que ela parte de tb_cardapio e faz junção com tb_cardapio_prato, para posteriormente chegar em tb_prato. Isso significa que a tabela em que a consulta está operando vai conter todos os cardápios e pratos associados.

Ao utilizar a cláusula GROUP BY em c.data (a data dos cardápios) e utilizar a função de agregação MAX, que retorna o maior valor de um determinado atributo para cada grupo, temos que a consulta irá trazer uma lista das datas em que houve cardápio e do valor máximo dentre os pratos servidos em cada um desses dias.

A existência da cláusula DISTINCT não faz tanto sentido, já que a tabela só iria retornar um registro por data de qualquer forma, devido ao GROUP BY.

Gabarito: D
37 – O Access é uma ferramenta de manipulação de dados em que os dados podem ser armazenados em estruturas relacionais chamadas tabelas. Cada linha na tabela é conhecida como registro, e os registros são formados por campos. A respeito de chaves primárias em tabelas do Access, considere as seguintes afirmativas:
  1. Chaves primárias são campos com valores comuns por toda a tabela.
  2. Cada tabela pode ter uma ou um conjunto de chaves primárias.
  3. O Access pode criar automaticamente um campo de chave primária.
  4. Cada registro na tabela possui um valor diferente de chave primária. .

Assinale a alternativa correta

a) Somente a afirmativa 1 é verdadeira.
b) Somente as afirmativas 2 e 3 são verdadeiras.
►c) Somente as afirmativas 3 e 4 são verdadeiras.
d) Somente as afirmativas 1, 2 e 4 são verdadeiras.
e) As afirmativas 1, 2, 3 e 4 são verdadeiras.

RESOLUÇÃO:
Vamos julgar as assertivas uma a uma:

  1. As chaves primárias são campos ou conjuntos de campos que possuem valores que identificam unicamente cada registro. Dessa maneira, não faz sentido dizer que essas chaves podem assumir valores comuns por toda a tabela. ERRADA
  2. Aqui é necessário fazer uma distinção importante. Como mostramos ao longo do curso, as tabelas podem ter chaves primárias simples ou compostas por mais de um atributo. Contudo, somente existe uma chave primária por tabela, em que pese a existência de múltiplas chaves candidatas. ERRADA
  3. O Access, assim como diversos SGBDs, possui recursos para criar chaves numéricas que sofrem incremento automático. Essas chaves são chaves substitutas, ou seja, que não possuem nenhum significado inerente, não representando nenhuma característica da entidade associada. Conforme citamos na nossa aula, no Access, ao criarmos uma tabela, por padrão ela já irá vir com um campo “Código”, do tipo numeração automática. Esse tipo é justamente o que está sendo tratado na assertiva, um valor numérico que sofrerá um incremento de uma unidade a cada novo registro adicionado. CERTA
  4. Esse é o propósito fundamental para a existência da chave primária, identificar unicamente cada registro. CERTA

Dessa maneira, somente 3 e 4 são verdadeiras.
Gabarito: C

#concurso iss curitiba #gabarito iss curitiba #informatica iss curitiba #prova iss curitiba #resolucao iss curitiba
Comentários

Central de Atenção ao Aluno